查看: 7594|回复: 7

[工具教程] [易语言][开源] 夜神模拟器操作模块v1.1(纯源码 没模块)

1

主题

2

帖子

7

积分

新手上路

Rank: 1

积分
7
a1133078 发表于 2017-9-30 08:10:06 | 显示全部楼层 |阅读模式
本帖最后由 a1133078 于 2017-9-30 08:21 编辑

原贴:https://bbs.yeshen.com/forum.php ... 0590&extra=page%3D1

源码由此贴的代码改进而来.
问题:
1. 如果模拟器安装在C:\Program Files 类似这种带空格路径的地方  会出现命令执行错误的提示
2. 参数都要带模拟器连接文本..过于麻烦  我给改成初始化时设置模拟器索引..在后面的代码不需要再传入[模拟器连接].也增加了一个置模拟器索引(模拟器索引)的命令
3. 如果是多个模拟器的话..可以把变量设置成数组.这样就不需要每次都要重置模拟器索引
4. 把他所需要的模块干掉了..真正的完完全全开源 不需要任何的模块..再也不怕别人的模块是否有暗桩或者恶意代码了
使用例子..在调用命令前必须先调用初始化 不然调用任何命令都会失败.



.版本 2
.全局变量 m_Nox, NOX

m_Nox.初始化 (0) ' 索引是从0开始的 0:第一个模拟器 1:第二个模拟器 如果注册表没有目录.请在第三个参数写上你的模拟器目录
m_Nox.ADB_模拟点击 (100, 123) ' 点击第一个模拟器的坐标100,123的位置
m_Nox.置模拟器索引 (1) ' 设置第二个模拟器
m_Nox.ADB_模拟点击 (100, 123) ' 点击第二个模拟器的坐标100,123的位置,因为上面改成了操作第二个模拟器
' 多个模拟器建议用数组来操作..不建议用置模拟器索引来来回更改操作

'数组操作
.版本 2

.全局变量 m_Nox, NOX, , "3"


.局部变量 i, 整数型
.计次循环首 (取数组成员数 (m_Nox), i)
    m_Nox .初始化 (i - 1)  ' 初始化所有的模拟器
.计次循环尾 ()
m_Nox [1].ADB_模拟按键 (123, 110)  ' 点击第一个模拟器的坐标123,110的位置
m_Nox [2].ADB_模拟按键 (100, 110)  ' 点击第二个模拟器的坐标100,110的位置


夜神v1.1.rar (10.42 KB, 下载次数: 1676)



上一篇:几个问题 希望改进
下一篇:运行战舰世界闪电战游戏时总是自动退出游戏
电脑玩手游,就用夜神安卓模拟器,www.yeshen.com免费下载使用夜神安卓模拟器。

0

主题

7

帖子

30

积分

新手上路

Rank: 1

积分
30
fyg5488 发表于 2017-12-3 10:11:57 | 显示全部楼层
把他所需要的模块干掉了
电脑玩手游,就用夜神安卓模拟器,www.yeshen.com免费下载使用夜神安卓模拟器。

0

主题

7

帖子

30

积分

新手上路

Rank: 1

积分
30
fyg5488 发表于 2017-12-3 09:29:33 | 显示全部楼层
惯例回复!学习了,谢谢分享!
电脑玩手游,就用夜神安卓模拟器,www.yeshen.com免费下载使用夜神安卓模拟器。

0

主题

7

帖子

30

积分

新手上路

Rank: 1

积分
30
fyg5488 发表于 2017-12-3 12:25:49 | 显示全部楼层
您好:这个
.子程序 启动模拟器, , 公开
.参数 虚拟机名称, 文本型
我应该怎么知道虚拟机的位置啊,我打算开3个模拟器!帮帮忙!!
电脑玩手游,就用夜神安卓模拟器,www.yeshen.com免费下载使用夜神安卓模拟器。

0

主题

3

帖子

12

积分

新手上路

Rank: 1

积分
12
用户481898128 发表于 2018-3-2 01:54:14 | 显示全部楼层
你好  请问下夜神模拟器   取模拟器信息怎么使用的?  怎么什么信息都取不到啊?
电脑玩手游,就用夜神安卓模拟器,www.yeshen.com免费下载使用夜神安卓模拟器。

1

主题

7

帖子

24

积分

新手上路

Rank: 1

积分
24
圣花猪 发表于 2018-4-21 20:36:26 | 显示全部楼层
夜神输入中文,怎么没说明
电脑玩手游,就用夜神安卓模拟器,www.yeshen.com免费下载使用夜神安卓模拟器。

0

主题

3

帖子

14

积分

新手上路

Rank: 1

积分
14
用户745492958 发表于 2018-8-13 15:19:15 | 显示全部楼层
                     
电脑玩手游,就用夜神安卓模拟器,www.yeshen.com免费下载使用夜神安卓模拟器。

0

主题

2

帖子

8

积分

新手上路

Rank: 1

积分
8
用户1229181187 发表于 2019-8-17 10:08:23 | 显示全部楼层
收藏...收藏...收藏...收藏...
电脑玩手游,就用夜神安卓模拟器,www.yeshen.com免费下载使用夜神安卓模拟器。
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则